質問は基本的に1スレッドにつき1つの内容でお願いします。

お問い合わせの際は下記の情報を明記をお願いいたします。

▼ソフトウェアに関するご質問の場合

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】例:Windows10、macOS HighSierra など
・【機種名】:MacBookPro 2017 など
・【グラフィックボード】例:GeForce GTX 950M など
・【メモリ】例:8GB
・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など
・【問い合わせ内容がわかるスクリーンショットまたは動画】例:パーツの表示状態など、お問い合わせ内容がわかる画像をご用意ください

---------------------------

▼SDKに関するご質問の場合

・現象の再現を行い検証させていただきますので、再現する最小のプロジェクトのご提供か、再現するまでの手順
・使用したSDKのバージョン

FaceRigでのQ~Yキーでのモーションが反映されない

【使用しているソフトウェア名とバージョン】Live2D Cubism Editor 3.2.04
【ご利用のPC環境】Windows10

はじめまして。よく参考にさせていただいております。
この度、FaceRigで自作モデルのQ~Yキーでのモーションが反映されず、こちらのコミュニティで回答されている内容をある程度試してみるもうまくいかなかったため、質問させていただくこととなりました。

[問題点]
FaceRigでQ~Yキーでのモーションが反映されない(モデルが変化しない)。

[ファイル構成]
chara

│ cc_chara.cfg
│ cc_names_chara.cfg
│ ico_chara.png
│ chara.moc3
│ chara.model3.json
│ chara.physics3.json

├─chara.1024
│ texture_00.png

└─motions
laugh.motion3.json

[cc_chara.cfgの中身]
set_cam_pos chara 0.0 0.0 1.0
set_special_action_anim chara 'laugh' 1
set_special_pose_param chara 'Param' 0 1 1
set_special_pose_param chara 'Param2' 0 1 2
cubism30_set_gravity chara 0 -1

[確認したこと]
・cc_chara.cfg内のset_special_action_anim以外の内容(カメラ位置、パラメータ変化、重力)は問題なく動作している。
・cc_chara.cfg内のset_special_action_animを他のすべてのキー(W~Y)にも割り当ててみたが、モーションは動作しなかった。
・cc_chara.cfg内のset_special_action_animの行を消去したり、cc_chara.cfgファイルを取り除いたりしてみたが、モーションは動作しなかった。
・'laugh'の部分を'laugh.motion3.json'に変化させてもモーションは動作しなかった。
・laugh.motion3.jsonファイルを書き出す際に「パーツ表示切替」を「書き出さない」にしている。
(デフォルトの「キーのあるパーツ」で書き出してFaceRigを起動しQキーを試すと、モデルが消えた。)
・Live2D Cubism Viewer 3.2で、モーションが動くことを確認した。
・FaceRigのカスタムキー設定を有効にしている。
(そのため、set_special_pose_param charaでのZ~Vキーでの動作は確認している。)
・FaceRigにデフォルトで存在する他のLive2Dモデルでは、Q(~W)キーが反応する。
・cc_chara.cfg内に「set_idle_anim chara 'laugh'」を追加すると、モーションが繰り返し再生された。
(ただし、この状態、またはここでset_idle_anim charaの一行を消した状態でも、Qキーでモーションは動作しない。)

以上です。
ご教授いただけると幸いです。

コメント

  • edited 09/12
    書式や設定などみると正しいです、
    他の人やツイッターでもモーションが動かないと言うのを見てます
    FaceRigまたは、Live2Dにバグが出たのかも
    うちの環境で過去に作ったのは動いてます、最新版Live2Dで書き出し検証も正常でした
  • 迅速な返信ありがとうございます!
    やはりバグでしょうか…こればかりはどうしようもないですね…
    mocやmtnの形式に直すか、パラメータ変化による出力で再現するかなどしてみようと思います
    ありがとうございました
Sign In or Register to comment.