質問は基本的に1スレッドにつき1つの内容でお願いします。

お問い合わせの際は下記の情報を明記をお願いいたします。

▼ソフトウェアに関するご質問の場合

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】例:Windows10、macOS HighSierra など
・【機種名】:MacBookPro 2017 など
・【グラフィックボード】例:GeForce GTX 950M など
・【メモリ】例:8GB
・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など
・【問い合わせ内容がわかるスクリーンショットまたは動画】例:パーツの表示状態など、お問い合わせ内容がわかる画像をご用意ください

---------------------------

▼SDKに関するご質問の場合

・現象の再現を行い検証させていただきますので、再現する最小のプロジェクトのご提供か、再現するまでの手順
・使用したSDKのバージョン

パーツ、デフォーマなどが削除できなくなる。

お疲れ様です。
モデルAからモデルBへ何かしらのパーツをコピーして張り付けまたは、パーツの書き出しをしてcmp3をBに投げこむ。
モデルAのパーツがモデルBへコピーされ、パラメータも問題なく動くのですが、なぜかその後パーツの削除、デフォーマの削除が行えなくなりました。
メッシュの変形、デフォーマの追加、PSDで新規にパーツを追加などは問題なく行えるのですが、パーツの削除、デフォーマの削除のみができなくなり。真っ赤なエラーログもたくさん出てしまう状態になりました。
過去に何回か同じようにモデルAからモデルBへパーツの移動デフォーマの移動などをしたことはあるのですが、今まで問題なくできていました。
今回初めてのトラブルなので対処法がわかりません。

エラー状況を見ていただけるのでしたら、自分のモデルでエラー再現出来ておりますので、お渡しいたしますので見ていただいて解決していただけると助かります。

コメント

  • zeru0303様

    ご連絡ありがとうございます。
    Live2D スタッフの虹子と申します。
    返信が遅くなりましたことお詫び申し上げます。

    このたびはCubism Editor 3においてパーツの移植を行った場合にオブジェクトの削除ができなくなるとのことでご不便をおかけしており、誠に申し訳ございません。

    原因の特定のため下記の三点を私宛にDMにてご送付いただければ幸いに存じます。

    1 モデルファイル
     問題の発生するモデルファイル(.cmo3)

    2 テキストファイル
     ご利用の環境と問題再現の手順について詳細を記載したテキストファイル(.txtなど)
     ・ご利用の環境について
      ・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.3.03 など)
      ・【ご利用のPC環境】例:Windows10、macOS HighSierra など
      ・【機種名】:MacBookPro 2017 など
      ・【グラフィックボード】例:GeForce GTX 950M など
      ・【メモリ】例:8GB
      ・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など

     ・問題再現の手順について
      ・再現時の手順と問題発生箇所(パーツ、オブジェクト名など)をご明記ください。

    3 ログファイル
     ・ご送付いただくログファイル
      メニューを[ヘルプ]、[ログファイルを開く]の順で選択します。
      開いたフォルダ内の[log.txt]を、上記の二点と併せて下記の手順にてご送付ください。

    ・DMの送信手順
      この返信の投稿者名[虹子(Staff)]をクリックします。
      開いたプロフィール画面右上の[メッセージ]をクリックします。
      [新しい会話を開始]が開きますので、アイコン[Attach file]をクリックしログファイルを選択します。
      
      [会話を開始する]をクリックし、ご送信ください。
      ファイルの添付が正しく行われない場合にはデータを格納したフォルダの圧縮を行ったのちご送信ください。

    お手数をおかけいたしまして誠に恐縮ではございますが、何卒よろしくお願い申し上げます。

  • お世話になっております。
    自分の方で色々検証した結果ですが、グルーが悪さをしていたようです。
    例えですが、Aモデルの1と2のパーツをグルーで結び付けていて、Aモデルの1のパーツだけ必要なのでコピーしてBのモデルへコピー移動した場合、グルーで結んでいたはずの2のパーツがないため問題が起こるみたいです。
    なのでグルーを消してから必要なパーツ1だけをコピーしてBモデルへ移動するか、グルーでつながっている1と2を一緒にコピーしてBモデルヘ移動すると問題は起こりませんでした。
コメントするにはサインインまたは登録して下さい。