ようこそ!

初めてですか? 参加するには、どちらかのボタンをクリックしてください!

【Live2D Creators Circleのご案内】
Live2Dでは現在、業務をお手伝いしていただけるユーザーの方々を募集しています。
もし、ご興味がありましたら下記URLより詳細をご確認ください。
https://goo.gl/0oBmkq

テクスチャアトラスの画質劣化について

モデル用画像よりもテクスチャアトラスで書き出したテクスチャが若干劣化してしまいます。





画像は肌の一部、30*105pixel程度の小さいパーツなのですが、
倍率を100%にして書き出ししてもまわりのフチが白っぽく劣化してしまいます。
小さいパーツですが必要な肌のパーツの一部ですので白っぽい部分が目立ちます。
モデル用画像表示(原寸)で見るとこのような劣化は見られません。

できれば直したいのですが、解決方法がわからない状態です。
もしくはこの程度の劣化は現状仕様なのでしょうか。

cubismはWin Pro版の最新のものを使用しています。
元画像はpsdデータで1500*3000pixel、解像度は350pixel/inchになります。
テクスチャアトラスは三枚に分け、すべて1024*1024、倍率は100%で配置しています。

何か解決策があればお願い致します。

コメント

  • acha0002様

    ご連絡ありがとうございます。
    Live2D スタッフの虹子です。

    このたびはテクスチャアトラスの画像が劣化するとのことでご迷惑をおかけしており誠に申し訳ございません。

    原因の特定のため下記の二点を私宛にDMにてご送付いただければ幸いに存じます。

    1モデルファイル(.cmo3)
     問題が発生しているモデルファイル。

    2 PSDファイル
     問題が発生しているモデルに読み込まれているすべてのPSDファイル。

     ・DMの送信手順
      この返信の投稿者名[虹子(Staff)]をクリックします。
      開いたプロフィール画面右上の[メッセージ]をクリックします。
      [新しい会話を開始]が開きますので、アイコン[Attach file]をクリックしログファイルを選択します。
      
      [会話を開始する]をクリックし、ご送信ください。

    お手数をおかけし大変恐縮ではございますが、何卒よろしくお願い申し上げます。
    acha0002
  • DMさせて頂きましたが、一応こちらにも。

    先程、三度目のアトラス用データの初期化を行い、メッシュの再配置を行ったところ
    理由は不明ですが劣化をしなくなりました。

    手順は何も変えていませんが、ひとまず劣化は直りましたのでこのまま制作を続けたいと思います。

    関係があるかは不明なのですが、経緯としましては

    手動で各メッシュを様々な倍率にして(拡縮して)配置し、出力

    テクスチャの劣化

    アトラス用データの初期化は行わない状態で、メッシュの倍率をすべて
    100%に設定し再配置し、出力

    同じテクスチャの劣化

    このため、今回問題のモデルファイル以外はアトラス用データの初期化を行い再配置を
    することで劣化はなくなっていましたが、今回のものは数回初期化を行わないと直りませんでした。

    再発するかはわかりませんが、アトラス用データの初期化は気をつけたいと思います。
  • edited 11/08
    上の劣化の問題ですが、メッシュ配置の際、元の角度から30~40?度以上回転を加えると劣化する状況が見られました。

    初期化を数回しないとならなかったのはその度手動で再配置をした際にメッシュに回転を加えるなどしていたからかと思われます。

    他の方も同条件で劣化が起こるかはわかりませんが(非常に微々たるものではあるので、影響のあるモデルも少ないかとは思います)、回転はあまり使わないほうが良かったかもしれません。

    ただ、テクスチャサイズとメッシュの倍率の関係で回転機能の使用は避けられませんので
    出来る限り対応を頂けますと幸いです。
Sign In or Register to comment.