質問は基本的に1スレッドにつき1つの内容でお願いします。

お問い合わせの際は下記の情報を明記をお願いいたします。

▼ソフトウェアに関するご質問の場合

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】例:Windows10、macOS HighSierra など
・【機種名】:MacBookPro 2017 など
・【グラフィックボード】例:GeForce GTX 950M など
・【メモリ】例:8GB
・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など
・【問い合わせ内容がわかるスクリーンショットまたは動画】例:パーツの表示状態など、お問い合わせ内容がわかる画像をご用意ください

---------------------------

▼SDKに関するご質問の場合

・現象の再現を行い検証させていただきますので、再現する最小のプロジェクトのご提供か、再現するまでの手順
・使用したSDKのバージョン

macでサンプルプロジェクトが動かない。

macでサンプルプロジェクトを取り入れてもエラーを吐いて動きません。
windowsでは同じ手順で動くことを確認しました。

os 10.12.4
unity 5.6.1f1(最新)

コメント

  • gkn 様

    ご報告ありがとうございます。
    どんなエラーが出ておられるでしょうか?
    もし「NullReferenceException」や「DllNotFoundException」でしたら、
    下記のチュートリアルページを参考に、ライブラリの設定をお願いいたします。

    ・ライブラリの設定について
    http://docs.live2d.com/euclid-sdk-tutorials/platform-libraries/

    ・macOS用の書き出し
    http://docs.live2d.com/euclid-sdk-tutorials/export-macos/

    この他のエラーメッセージでしたら、サンプルプロジェクト名とエラーメッセージをお教え願えますでしょうか?
  • ご返信ありがとうございます。
    ライブラリの設定を行いましたが現象はかわらずです。

    sample project simple
    http://d.kuku.lu/939271d68e
  • gkn 様

    エラーの先頭に「DllNotFoundException」が出ているのでやはりライブラリの設定かと思われます。

    「Assets/EuclidSDK/Plugins/x64」ディレクトリ下に「EuclidSDKNative.dll」と「EuclidSDKNative.bundle」という
    二つのライブラリがあるのですが、mac環境ではこのうち「.dll」の方のチェックを全て外し、「.bundle」の方の
    「Editor」と「Standalone」にチェックを入れていただくとエラーが解消されるのではないかと思います。

    Unityの仕様で、プロジェクトウィンドウのアイコンには拡張子が表示されず、アイコンの下にあるスライドバーの
    左側に書かれたファイル名でしか判別できないため大変紛らわしく恐縮なのですが、
    ここの設定のご確認をお願いしてよろしいでしょうか?

  • エラーが解消され
    動かすことができました!

    ご対応ありがとうございます!
    t_takasaka (Staff)
Sign In or Register to comment.