質問は基本的に1スレッドにつき1つの内容でお願いします。

お問い合わせの際は下記の情報を明記をお願いいたします。

▼ソフトウェアに関するご質問の場合

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】例:Windows10、macOS HighSierra など
・【機種名】:MacBookPro 2017 など
・【グラフィックボード】例:GeForce GTX 950M など
・【メモリ】例:8GB
・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など
・【問い合わせ内容がわかるスクリーンショットまたは動画】例:パーツの表示状態など、お問い合わせ内容がわかる画像をご用意ください

---------------------------

▼SDKに関するご質問の場合

・現象の再現を行い検証させていただきますので、再現する最小のプロジェクトのご提供か、再現するまでの手順
・使用したSDKのバージョン

Model has black edges when loading via script



I refered to the following script
http://docs.live2d.com/cubism-sdk-tutorials/initializemodel/

but when I drag the model prefab to scene, it shows correctly.
How to solve this issue? Thanks

コメント

  • Hi,

    Depending on the condition of calculation of alpha blend of texture set by Unity, this trouble happens. I'd like you to click "Apply" button with "Alpha Is Transparency" checked in Inspector window after selecting texture.

    Thanks,

  • Hi,

    Depending on the condition of calculation of alpha blend of texture set by Unity, this trouble happens. I'd like you to click "Apply" button with "Alpha Is Transparency" checked in Inspector window after selecting texture.

    Thanks,


    Thank you for your answer, but I want to load image with Texture.LoadImage() function, and I tried to set texture.alphaIsTransparency to true but not work. Is there any way to approach to it? Thanks.
  • Hi, I have the same problem described in this thread.
    What I found is that the BuiltinLoadAssetAtPath function actually is creating a new Texture2D instead of using the texture already imported to the project.
    I changed the code when the assetType is Texture2D to using Resources.Load and put the imported texture under a Resources folder. I wonder if this solution may cause any problems. While, even using texture.LoadImage, you need to make sure the texture is within build so putting the texture under a Resources folder seems necessary.
    Another way I can think is directly load the prefab instead of using the ToModel() things.
    Can you explain the pros and cons of directly loading the prefab and using the ToModel() things (as described in the SDK manual)
    Thank you.
Sign In or Register to comment.