質問は基本的に1スレッドにつき1つの内容でお願いします。

お問い合わせの際は下記の情報を明記をお願いいたします。

▼ソフトウェアに関するご質問の場合

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】例:Windows10、macOS HighSierra など
・【グラフィックボード】例:GeForce GTX 950M など
・【メモリ】例:8GB
・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など
・【問い合わせ内容がわかるスクリーンショットまたは動画】

---------------------------

▼SDKに関するご質問の場合

・現象の再現を行い検証させていただきますので、再現する最小のプロジェクトのご提供か、再現するまでの手順
・使用したSDKのバージョン

iosにおけるlive2dの位置調整

現在ティラノビルダーでのiosアプリの製作を行なっているのですが、pc上でプレビューした時と、xcodeのエミュレーター上でのモデルの位置が大きくずれてしまいます。
特にビルドエラーも出ず、このモデルの位置だけがずれ、それ以外は正常に動作しています。
これはxcode上でどの部分を書き換えれば治るでしょうか?
なにぶん、初めてのことなので途方にくれております、ご教授の方よろしくお願い致します。


コメント

  • @Tosaka様

    Live2Dスタッフの小嶺と申します。
    最新のTyranoBuilderで確認してみたところ、スクリプト画面上のプレビューボタンでは保存せずにプレビューが反映されるという特性があるようです。
    問題のスクリーンショットも見たところ原点位置に戻ってるように見えますので、
    1、Live2Dを追加した時点で保存した
    2、位置を移動してから画面上のプレビューボタンで位置を確認した
    3、2の状態を書き出そうとしてみたが実際は1の状態が書き出されている
    このようなことが起こってるのではないかと考えています。
    なお、メニューバーからプレビューをすると変更があった時に保存するか確認されるようです。

    まずは保存したことを確認してからゲームを書き出して、
    「(書き出しプラットホーム_書き出し日時)¥data¥scenario¥(書き出したスクリプト).ks」のlive2d_show命令に意図した位置情報が書き込まれているか確認していただければと思います。

    上記の解決案でうまくいかなかった場合は、
    ・プロジェクトの作成時に指定したウインドウサイズ、
    ・書き出し時の設定、特に「ウインドウの縮小を許可」にチェックを入れたかどうか?
    ・ios側での解像度の設定
    以上情報をお教えいただければ一段踏み込んで調べることができると思います。
    よろしくお願いいたします。
  • お返事ありがとうございます。
    ですが保存はできていたようで、書き出したスクリプトにも意図した位置情報が書き込まれておりました。

    ・ウインドウサイズですが、横960px、縦640pxのようです。
    ・「ウインドウの縮小を許可」という欄が見当たらなかったのですが、「端末に合わせて自動調整する」、もしくは「端末に合わせて自動調整するが、縦横比率は崩さない」の2通りを試したところ改善しませんでした。
    ・解像度を特に指定しておらず、確認の方法がよくわからないのですが、iphone5s,6s,8のいずれにおいても同じ症状が出ております。

    お手数ですが、何卒よろしくお願い致します。
  • @Tosaka様

    こちらでも同様の設定の上、xcodeで調査してみましたが今回のような症状の再現はできませんでした。

    こちらの環境はティラノビルダー1.80b、ティラノプレイヤーv111、xcode9.3、Simulator10.0で行っています。

    Live2Dの表示系の問題なのか、それ以外の問題なのか切り分けたいので
    ・表示のタイミングを変えられるか?その際位置は問題あるままか?
    ・他のモデルを追加できるか?すべてのモデルで位置問題が起こるのか?問題が一部のモデルに偏るのか?
    ・横の位置は動かせないか?
    以上3点をお試しいただけますか?
    また、書き出したプロジェクトが確実にxcode側にコピーされているかも合わせてご確認いただければとおもいます。

    よろしくお願いいたします。

  • 3点確認しました。


    ・タイミング変えられますが、位置は依然問題のままです。
    ・他のモデルの追加できましたが、同様に位置がおかしいです。
    ・横、縦共に動きません、何度か数値を変えて試しましたがダメでした。

    コードも正常に書き出されており、コピーも問題なくできていると思われます。

    よろしくお願い致します。
  • @Tosaka様

    3点確認、ありがとうございます。
    調査の中でTyranoBuilder掲示板で同様のトラブルの解決案が掲載されていたのを見つけたので紹介させていただきます。
    http://tyranobuilder.bbs.fc2.com/reply/7499136/75/

    同様の修正は最新のスクリプトに適用されてるようにみられるので
    ティラノビルダー、ティラノプレイヤーのアップデートがまだでしたらご検討いただければと思います。
  • 小嶺様

    問題解決致しました。
    迅速な対応、誠にありがとうございました。
Sign In or Register to comment.