質問は基本的に1スレッドにつき1つの内容でお願いします。

お問い合わせの際は下記の情報を明記をお願いいたします。

▼ソフトウェアに関するご質問の場合

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】例:Windows10、macOS HighSierra など
・【機種名】:MacBookPro 2017 など
・【グラフィックボード】例:GeForce GTX 950M など
・【メモリ】例:8GB
・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など
・【問い合わせ内容がわかるスクリーンショットまたは動画】例:パーツの表示状態など、お問い合わせ内容がわかる画像をご用意ください

---------------------------

▼SDKに関するご質問の場合

・現象の再現を行い検証させていただきますので、再現する最小のプロジェクトのご提供か、再現するまでの手順
・使用したSDKのバージョン

モデルのインポートについて

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】Windows7
・【グラフィックボード】GeForce GTX 1070
・【メモリ】例:32GB

Unity2017.3にてモデルをインポートしようとした際にエラーが表示し、詰まっています。
▼ライブラリの設定についてを読みましたが、SDKの中のlibEuclidSDKExternal.dllが見つかりません出した。
http://docs.live2d.com/euclid-sdk-tutorials/platform-libraries/

コメント


  • ▲このようなエラー文です
  • 24pon 様

    お問い合わせありがとうございます。
    チュートリアルの記述が以前のバージョンの内容になっており申し訳ありません。
    Windows用のライブラリは下記の二つとなります。

    EuclidSDK\Libraries\x64_iOS_Android\Shared\EuclidEngine.dll
    EuclidSDK\Plugins\x64\EuclidSDKNative.dll

    上記ライブラリの設定を行ってもまだエラーが表示される場合は、以下を教えていただけますと助かります。
    ・SDKのバージョン
    ・インポートしようとしたモデルはサンプルで配布されているものか、または自作したオリジナルモデルか
    ・オリジナルモデルの場合は制作したエディタのバージョン

    以上となります。よろしくお願いいたします。
  • こんばんわ。
    回答ありがとうございます。
    設定箇所を見つけることができました。

    ただ今度は、アンドロイドのビルドで詰まっています。
  • Assets/EuclidSDK/Editor/EuclidModelEditor.cs(13,55): error CS0234: The type or namespace name `EuclidConfigEditor' does not exist in the namespace `live2d.Euclid_Editor'. Are you missing an assembly reference?
    Assets/EuclidSDK/Editor/EuclidModelEditor.cs(15,42): error CS0115: `EuclidModelEditor.configure' is marked as an override but no suitable property found to override
    Assets/EuclidSDK/Editor/EuclidModelEditor.cs(19,31): error CS0115: `EuclidModelEditor.configurePath' is marked as an override but no suitable property found to override
    Assets/EuclidSDK/Editor/EuclidModelEditor.cs(24,26): error CS0115: `EuclidModelEditor.OnInspectorGUI()' is marked as an override but no suitable method found to override
    ▲このような場合どのように設定をすればよいのでしょうか?
  • 24pon 様

    下記手順でご確認をお願いしてもよろしいでしょうか?

    1.UnityのProjectウィンドウで以下のdllを選択する
    EuclidSDK\Libraries\x64_iOS_Android\EuclidEditor.dll

    2.Inspectorウィンドウの「Select platforms for plugin」にある「Editor」にチェックが入っているかを確認する

    以上となります。よろしくお願いいたします。
  • t_takasaka (Staff) 様

    ご教授ありがとうございます。
    設定を行い挑戦してみようと思います。
    ありがとう御座います。
Sign In or Register to comment.