質問は基本的に1スレッドにつき1つの内容でお願いします。

お問い合わせの際は下記の情報を明記をお願いいたします。

▼ソフトウェアに関するご質問の場合

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】例:Windows10、macOS HighSierra など
・【グラフィックボード】例:GeForce GTX 950M など
・【メモリ】例:8GB
・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など
・【問い合わせ内容がわかるスクリーンショットまたは動画】

---------------------------

▼SDKに関するご質問の場合

・現象の再現を行い検証させていただきますので、再現する最小のプロジェクトのご提供か、再現するまでの手順
・使用したSDKのバージョン

OpenGL版SDK(v2.2.1.05_1)のsampleプロジェクトがVisual Stuido 2015の64bit版でビルドできない

OpenGL版SDK(2.2.1.05_1)のsampleプロジェクトがVisual Stuido 2015の64bit版でビルドできませんでした.

SDK(2.2.1.05_1)の更新履歴の
> sampleプロジェクトで使用しているライブラリの階層を修正しました。
に書いてあるように,バージョン2.2.1.05_1からsampleプロジェクトの/thirdParty/libpng/lib/x64の下に,
VSのバージョン?に合わせて,100, 110, 120, 140と階層化されているようです

しかしながら,VS2015の64bit版のターゲットとなる/sample/thirdParty/libpng/lib/x64/140ディレクトリにあるzlib.lib, libpng16.libがVS2015で利用できないようです.
したがって,libpngを自分でビルドして140ディレクトリのzlib.lib, libpng16.libを置き換えてしまえばビルドできるようになります.

難しいことではないのですが,sampleプロジェクトはすぐに動かしたい方もおられると思いますので,とりあえずご報告させていただきました.

コメント

Sign In or Register to comment.