質問は基本的に1スレッドにつき1つの内容でお願いします。

お問い合わせの際は下記の情報を明記をお願いいたします。

▼ソフトウェアに関するご質問の場合

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】例:Windows10、macOS HighSierra など
・【機種名】:MacBookPro 2017 など
・【グラフィックボード】例:GeForce GTX 950M など
・【メモリ】例:8GB
・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など
・【問い合わせ内容がわかるスクリーンショットまたは動画】例:パーツの表示状態など、お問い合わせ内容がわかる画像をご用意ください

---------------------------

▼SDKに関するご質問の場合

・現象の再現を行い検証させていただきますので、再現する最小のプロジェクトのご提供か、再現するまでの手順
・使用したSDKのバージョン

自作motion3.jsonがCubism Viewerで想定通りに動作しない

Cubism Editor3でモーションをつけてmotion3.jsonに書き出したのですが、
Cubism Viewer3で再生したところ、想定通りに動作しませんでした。

具体的には、顔の角度Yを0→-30→0と設定し、頷きモーションを作りました。
そして、Editor上や動画書き出しでは頷きモーションが再生されることが確認できました。

ところが、書き出したmotion3.jsonをViewerにドラッグ&ドロップし、再生すると、
微妙に動きはするのですが、Editorや動画のように頷いてはくれません。

解決策や心当たりがあれば教えていただけませんでしょうか?
環境は以下の通りです。
【Cubismバージョン】3.3.03
【モデル】桃瀬ひよりCubism3 FREE用
【OS】Win10

また、以下が書き出したmotion3.jsonファイルの中身です。

{
"Version": 3,
"Meta": {
"Duration": 0.667,
"Fps": 30.0,
"Loop": true,
"AreBeziersRestricted": false,
"CurveCount": 3,
"TotalSegmentCount": 5,
"TotalPointCount": 16,
"UserDataCount": 0,
"TotalUserDataSize": 0
},
"Curves": [
{
"Target": "Parameter",
"Id": "ParamAngleX",
"Segments": [
0,
0,
1,
0.111,
0,
0.222,
0,
0.333,
0,
1,
0.444,
0,
0.556,
0,
0.667,
0
]
},
{
"Target": "Parameter",
"Id": "ParamAngleY",
"Segments": [
0,
0,
1,
0.111,
0,
0.222,
-30,
0.333,
-30,
1,
0.444,
-30,
0.556,
0,
0.667,
0
]
},
{
"Target": "Parameter",
"Id": "ParamAngleZ",
"Segments": [
0,
0,
0,
0.667,
0
]
}
]
}

以上、よろしくお願いいたします。

コメント

  • 07/01編集されました
    kanosawa 様

    お問い合わせ誠にありがとうございます。
    Live2Dスタッフのenokoでございます。

    この度はご不便をおかけしており誠に申し訳ありません。
    お手数ですが、cmo3やcan3、書き出したファイルなど一式を私までDMでお送りいただけますでしょうか。

    ・DMの送信手順
     この返信の投稿者名[enoko(staff)]をクリックします。
     開いたプロフィール画面右上の[メッセージ]をクリックします。
     [新しい会話を開始]が開きますので、アイコン[Attach file]をクリックしログファイルを選択します。
     [会話を開始する]をクリックし、ご送信ください。

    お手数おかけしますが、
    何卒宜しくお願い申し上げます。
  • enoko様

    kanosawaです。
    迅速なご対応ありがとうございます。
    DMお送りしましたので、よろしくお願いいたします。
  • 07/05編集されました
    konosawa様


    DMでのご連絡も誠にありがとうございます!

    本件の現象の原因は、
    モーションのフェードイン・アウトの設定の影響を受けて意図通り再生されていないためです。

    https://docs.live2d.com/cubism-editor-manual/fade-setting/
    ↑こちらの設定で、「設定対象」を「シーン」に設定し、
    「フェードイン」「フェードアウト」の値を「0」秒に設定し、
    シーンを組み込み用に書き出すことにより正しく再生されます。
    お試しくださいませ。

    お手数をおかけしますが、何卒宜しくお願い申し上げます。
  • enoko様

    kanosawaです。
    無事に動作しました! ありがとうございました!
コメントするにはサインインまたは登録して下さい。