質問は基本的に1スレッドにつき1つの内容でお願いします。

お問い合わせの際は下記の情報を明記をお願いいたします。

▼ソフトウェアに関するご質問の場合

・【問題が発生したソフトウェア名とバージョン】(例:Cubism Editor 3.1.02、Euclid Editor 1.2.0 など)
・【ご利用のPC環境】例:Windows10、macOS HighSierra など
・【機種名】:MacBookPro 2017 など
・【グラフィックボード】例:GeForce GTX 950M など
・【メモリ】例:8GB
・【原画(イラスト)を制作したソフトウェア】例:Photoshop , CLIP STUDIO , SAI など
・【問い合わせ内容がわかるスクリーンショットまたは動画】例:パーツの表示状態など、お問い合わせ内容がわかる画像をご用意ください

---------------------------

▼SDKに関するご質問の場合

・現象の再現を行い検証させていただきますので、再現する最小のプロジェクトのご提供か、再現するまでの手順
・使用したSDKのバージョン

Unity5.6でモデルが表示されない

初心者のため初歩的な質問で大変失礼します。

Unity5.6で”sampleApp1を利用したプロジェクト作成”に挑戦しているのですが、SceneにもGameにもモデルが表示されません。
類似のディスカッションを見て何度も試しているのですが同じでした。

作業環境
OS:windows10
Cubisumのバージョン:2.1 64bit
Unityのバージョン:5.6.1f1 Personal
SDKのバージョン:2.1.04_1

使用しているモデルはSDKのSampleに入っているwankoです。
moc、json、mtnファイルの拡張子にに.bytesが付いてるか確認済みです。
モデルデータはResourcesにlive2dフォルダを作り、その中に入れています。

LAppModelProxyのPathは/Resources/live2d/wanko1/wanko.model.jsonで指定しています。

live2dフォルダを作らず、Resourcesの直下に置いてlive2d/wanko1/wanko.model.jsonでも試してみましたがダメでした。

再生すると”NullReferenceException: Object reference not set to an instance of an object”というエラーが出ます。

Demoはモデルが表示され、自作モデルに差し替えても表示されました。

expressionsフォルダ内のjsonファイルにも.bytesが必要でしょうか?
自分なりに調べているのですが先に進めず困っています。よろしくお願い致します。

コメント

  • @roomno445 さん

    LAppModelProxyに指定するパスですが、マニュアルの該当ページの「◆LAppModel の設定」にあるとおり、
    こちらはResourcesフォルダからの相対パスになります。

    例えば、Resourcesフォルダ直下にwanko.model.jsonを配置した場合、指定するパスは以下になります。
    wanko.model.json

    また、Resourcesフォルダに「live2d」という名前でフォルダを作り、そのフォルダ内にwanko.model.jsonを配置した場合は以下のパスになります。
    live2d/wanko.model.json
  • 早速のお返事ありがとうございました。

    ご指摘頂いたとおりResourcesフォルダからの相対パスに変更したのですが、症状は同じでした。

    初めからまた調べ直します。ありがとうございます。
  • 解凍ソフトが古くダウンロードしたファイルが完全に解凍されていなかったようです。
    ソフトを変えたら正常に動作しました。ありがとうございました。
Sign In or Register to comment.