新しいLive2D公式コミュニティ(日本向け)が公開されました!
ぜひご利用ください!
Live2D公式コミュニティ

■このコミュニティの今後について
このコミュニティ(forum.live2d.com)につきましては、しばらくの間新コミュニティと並行して運営しますが、2022年内を目処に閉鎖する予定です。
閉鎖時期や内容については決定次第お知らせいたします。
海外向けコミュニティについては変更ございません。
Live2Dに関するユーザーのみなさま同士の交流・ご質問・不具合の報告・提案・要望などについて是非お寄せください。
※Live2D公式スタッフからの発言や回答については確約できないことを予めご了承ください。

Live2D ヘルプ

Cubism Editorダウンロード / 動作環境
Cubism SDKダウンロード / 対応表
Cubism 製品利用ライセンス(SDK含)

Cubism 製品のライセンスについてのお問い合わせはこちら
nizima 及び nizima 製品についてのお問い合わせはこちら
【各最新OSの対応状況について】
Cubism Editorは 4.1.02 正式版以降でWindows 11 及び macOS Monterey に対応しております。ぜひ最新版をご利用ください。
※macOSをお使いの方でOSアップデートする際は必ずCubism Editorのライセンスを解除してください。
Cubism EditorをインストールしているmacOSをアップグレードしたい
Cubism SDKについては各SDKのREADMEまたはNOTICEをご確認ください。

【Mac各機種への対応状況について】
現在、Cubism EditorはApple M1チップ搭載機種には対応しておりません。
詳細は 動作環境 をご参照ください。
関連するお問い合わせへの対応はこの文章をもって代えさせていただきます。
Cubism 製品のマニュアル・チュートリアルはこちら
 
Cubism Editorマニュアル    Cubism Editorチュートリアル    Cubism SDKマニュアル    Cubism SDKチュートリアル

Unity5.6でモデルが表示されない

初心者のため初歩的な質問で大変失礼します。

Unity5.6で”sampleApp1を利用したプロジェクト作成”に挑戦しているのですが、SceneにもGameにもモデルが表示されません。
類似のディスカッションを見て何度も試しているのですが同じでした。

作業環境
OS:windows10
Cubisumのバージョン:2.1 64bit
Unityのバージョン:5.6.1f1 Personal
SDKのバージョン:2.1.04_1

使用しているモデルはSDKのSampleに入っているwankoです。
moc、json、mtnファイルの拡張子にに.bytesが付いてるか確認済みです。
モデルデータはResourcesにlive2dフォルダを作り、その中に入れています。

LAppModelProxyのPathは/Resources/live2d/wanko1/wanko.model.jsonで指定しています。

live2dフォルダを作らず、Resourcesの直下に置いてlive2d/wanko1/wanko.model.jsonでも試してみましたがダメでした。

再生すると”NullReferenceException: Object reference not set to an instance of an object”というエラーが出ます。

Demoはモデルが表示され、自作モデルに差し替えても表示されました。

expressionsフォルダ内のjsonファイルにも.bytesが必要でしょうか?
自分なりに調べているのですが先に進めず困っています。よろしくお願い致します。

コメント

  • @roomno445 さん

    LAppModelProxyに指定するパスですが、マニュアルの該当ページの「◆LAppModel の設定」にあるとおり、
    こちらはResourcesフォルダからの相対パスになります。

    例えば、Resourcesフォルダ直下にwanko.model.jsonを配置した場合、指定するパスは以下になります。
    wanko.model.json

    また、Resourcesフォルダに「live2d」という名前でフォルダを作り、そのフォルダ内にwanko.model.jsonを配置した場合は以下のパスになります。
    live2d/wanko.model.json
  • 早速のお返事ありがとうございました。

    ご指摘頂いたとおりResourcesフォルダからの相対パスに変更したのですが、症状は同じでした。

    初めからまた調べ直します。ありがとうございます。
  • 解凍ソフトが古くダウンロードしたファイルが完全に解凍されていなかったようです。
    ソフトを変えたら正常に動作しました。ありがとうございました。
コメントするにはサインインまたは登録して下さい。