Cubism 製品のマニュアル・チュートリアルはこちら
 
Cubism Editorマニュアル    Cubism Editorチュートリアル    Cubism SDKマニュアル    Cubism SDKチュートリアル

AEエクスプレッション 異なるパラメータを参照したい場合

after effctsにて読み込んだモデルデータにアニメーションを付けています。
右目と左目の動きを完全に同期させるため、
「右目 開閉」パラメータに以下のエクスプレッションを適用しました。
effect("Live2D Cubism Renderer")("左目 開閉 [ParamEyeLOpen]")
※同じレイヤーの「左目 開閉」パラメータの内容を参照

そうすると以下のエラーが吐き出されます。
Error:クラス「Group」の「左目 開閉 [ParamEyeLOpen]」という名前のプロパティ
またはメソッドが見つからないか、存在しません。名前が変更されたか、
移動または削除された、あるいは名前の入力が間違っている可能性があります。

エラーが吐き出されていますが、タイムラインウィンドウ内での「右目 開閉」パラメータの数値は
エクスプレッションの内容通りに変動しています。
コンポジションウィンドウでのプレビューはエクスプレッションの内容が反映されていません。

以下の場合でも同様のエラーが起きていました。
・同じコンポジションの異なるレイヤー内パラメータを参照
thisComp.layer("レイヤー名").effect("Live2D Cubism Renderer")("左目 開閉 [ParamEyeLOpen]")
・異なるコンポジションのレイヤー内パラメータを参照
comp("コンポ名").layer("レイヤー名").effect("Live2D Cubism Renderer")("左目 開閉 [ParamEyeLOpen]")

異なるパラメータのエクスプレッションを反映させるためにはどうすればいいでしょうか?

[補足]
■Aeバージョン:cc2020
■Live2D Cubism Renderer バージョン:R2
■Live2D バージョン:4.0

コメント

  • n0a_l2d様

    ご質問誠にありがとうございます。
    Live2Dスタッフでございます。
    いつも弊社製品をご愛顧くださり誠にありがとうございます。

    この度はご不便をおかけして誠に申し訳ございません。
    現状での対応方法は何かしらのモデルのプロパティの値を操作することで、
    内部で持っているプロパティの名称が更新されてエラーが発生しなくなります。
    こちらの不具合は、引き続き調査をすすめてまいります。

    今後とも弊社製品をお引き立ての程宜しくお願い申し上げます。
  • enoko さん

    ご返答ありがとうございます。
    エラー自体を無くすことはできたのですが、やはりコンポジションウィンドウでのプレビューでは
    エクスプレッション(目のまばたき)の内容が反映されていませんでした…。
    大変お手数ですが調査お願い致します。
  • n0a_l2d様

    ご連絡誠にありがとうございます。

    https://www.live2d.com/download/sample-data/
    念の為、公式サンプルモデルの「ライス・グラスフィールド」を使用していただき、
    解決するかどうかをお試しいただけますでしょうか…

    それでも解決しない場合は、
    作業手順と結果の一部始終がわかるようにご教示いただけますでしょうか。
    キャプチャ動画も添えていただきますと大変ありがたいです。
    公開できない内容の場合はDMにてお送りください。

    ★DMの送信手順
     この返信の投稿者名[enoko(staff)]をクリックします。
     開いたプロフィール画面右上の[メッセージ]をクリックします。
     [新しい会話を開始]が開きますので、アイコン[Attach file]をクリックしファイルを選択します。
     [会話を開始する]をクリックし、ご送信ください。
    (ファイルは圧縮していただくか、
     サイズが大きくて添付できない場合はアップロードサイトなどをご利用下さい)

    お手数をおかけし申し訳ございませんが
    何卒宜しくお願い申し上げます。
  • enoko さん

    返答が遅くなり申し訳ありません。
    記載頂いたURL先のモデルを使用し、同様のエクスプレッションを付けてみたところ、
    正常にエクスプレッションが適用されました。

    プレビューがうまく表示されていなかった自分のデータで色々試してみたところ、
    モデルデータの新規コンポジションを作成しなおし、再度エクスプレッションを付けることでプレビューも正常に再生されました。
    また、新規コンポジションを作成せず、プロジェクトウィンドウからモデルデータを既存のコンポジションに持ってくることでも解決しました。
    原因が明確に分からない状況ですが、内部に残り続けている古いキーフレームの情報が増えたのが原因でしょうか…。

    現状は上記の方法でエクスプレッションの活用が出来そうです!
    色々とお手数をお掛けして大変申し訳ありません…。
  • n0a_l2d様

    ご確認誠にありがとうございます。

    AE側の仕様により、今のところは根本の解決が難しい部分のため
    当面は前述の回避策を行っていただくしか方法がございません。

    お手数をおかけしますが、何卒宜しくお願い申し上げます。
    今後とも弊社製品をお引き立ての程宜しくお願い申し上げます。
コメントするにはサインインまたは登録して下さい。