新しいLive2D公式コミュニティ(日本向け)が公開されました!
ぜひご利用ください!
Live2D公式コミュニティ

■このコミュニティの今後について
このコミュニティ(forum.live2d.com)につきましては、しばらくの間新コミュニティと並行して運営しますが、2022年内を目処に閉鎖する予定です。
閉鎖時期や内容については決定次第お知らせいたします。
海外向けコミュニティについては変更ございません。
Live2Dに関するユーザーのみなさま同士の交流・ご質問・不具合の報告・提案・要望などについて是非お寄せください。
※Live2D公式スタッフからの発言や回答については確約できないことを予めご了承ください。

Live2D ヘルプ

Cubism Editorダウンロード / 動作環境
Cubism SDKダウンロード / 対応表
Cubism 製品利用ライセンス(SDK含)

Cubism 製品のライセンスについてのお問い合わせはこちら
nizima 及び nizima 製品についてのお問い合わせはこちら
【各最新OSの対応状況について】
Cubism Editorは 4.1.02 正式版以降でWindows 11 及び macOS Monterey に対応しております。ぜひ最新版をご利用ください。
※macOSをお使いの方でOSアップデートする際は必ずCubism Editorのライセンスを解除してください。
Cubism EditorをインストールしているmacOSをアップグレードしたい
Cubism SDKについては各SDKのREADMEまたはNOTICEをご確認ください。

【Mac各機種への対応状況について】
現在、Cubism EditorはApple M1チップ搭載機種には対応しておりません。
詳細は 動作環境 をご参照ください。
関連するお問い合わせへの対応はこの文章をもって代えさせていただきます。
Cubism 製品のマニュアル・チュートリアルはこちら
 
Cubism Editorマニュアル    Cubism Editorチュートリアル    Cubism SDKマニュアル    Cubism SDKチュートリアル

アバター一覧に表示させるアイコンが反映されません。

編集済: 3月 2021 Facerig+Live2D Module
live2Dで自作したキャラクターをfaceRigへ取り込んだところ、モデルは問題なく表示されましたが、
アバター一覧の表示が作成したアイコンではなく、faceRigのデフォルト?のものになってしまいまいます。
名前の確認やアイコンのサイズも確認しましたが問題ないように見えるため、原因が分かりません。
また、試しにアイコンをフォルダから削除してみたところ[?]のアイコンではなく、
上記のfaceRigのデフォルトのものになってしまいました。


試しに、ほかのアバター一覧の.png画像を対象フォルダへ名前のみ変更して入れてみましたが、やはり反映されませんでした。
こちらのサイトの解決方法を見てみましたが、解決しないためご教授いただければ幸いです。

コメント

  • 編集済: 3月 2021
    いろいろ謎ですね
    cc_names_モデル名.cfgが無いのにモデル名やカタカナで文字が出てる
    ファイルの実態が違うのかも

    あと、FaceRig\Mod\VP\PC_Common\Objects\ に入れた場合どうなるかは不明、未調査
       FaceRig\Mod\VP\PC_CustomData\Objects\ を推奨
    夢風鈴
  • xsinryux_xさん、コメントありがとうございます。
    cc_names_モデル名.cfg については確認したところ、モデル名・キャラクターの説明文が正常に反映されたため、試しにnamesを消してフォルダへ入れたとこ、上記のように問題なく表示されました。一度フォルダごと削除し、faceRigの立ち上げ→終了を行ってから、モデル一覧のフォルダへ該当フォルダを入れ直しも行いましたが、同じ状態で表示されました。
    どこかにログのようなものが残ってしまっていて、それが読み込まれてしまっているのでしょうか。。。
  • 編集済: 3月 2021
    ファイル構成が正しい場合、
    PNGの形式が原因なのかも、サイズが巨大とか、透過になってるとかPNG8、PNG24以外とか、作成ソフトの相性とか
    夢風鈴
  • xsinryux_xさん、追記ありがとうございます。
    お教えいただきましたパス[PC_CustomData\Objects\]を確認したところ、なぜかフォルダが今回の対象フォルダができており、
    上に載せましたfaceRigのデフォルト?の画像が入っていました。
    おそらく[PC_Common\Objects\]に入っていたデータを読み込ませた際に自動的に作成されてしまったのではないかと思われます。
    PC_Commonのフォルダと該当のフォルダの画像データ削除後、データの入れ直しを行ってみましたが症状は改善しなかったため、
    一度フォルダを削除→新たに同名フォルダを作成しデータを入れ直しを行ったところ、無事正常にデータが反映され一覧のサムネイルが表示され、モデルデータも問題なく動きました。
    .pngの保存形式が透過になっていると(?)の上にキャラクター画像が表示されることも確認できました。
    大変助かりました。ありがとうございました。



コメントするにはサインインまたは登録して下さい。