【Mac各機種への対応状況について】
現在、Cubism EditorはApple M1チップ搭載機種には対応しておりません。
詳細は 動作環境 をご参照ください。
関連するお問い合わせへの対応はこの文章をもって代えさせていただきます。
また、Cubism SDKは現在公開中の製品全てにおいてApple M1チップ搭載機種及びmacOS 11.0 Big Surには対応しておりません。
Cubism 製品のマニュアル・チュートリアルはこちら
 
Cubism Editorマニュアル    Cubism Editorチュートリアル    Cubism SDKマニュアル    Cubism SDKチュートリアル

[解決]CubismWebのDemoがbuildできない

編集済:06/14 Cubism 4 SDK
以下のチュートリアルの手順に沿ってDemoプロジェクトをビルドしようとしたのですが、エラーが出てしまいます。
思い当たる解決方法等ありましたら、教えていただけますでしょうか。

○○\CubismSdkForWeb-4-r.3\Samples\TypeScript\Demo\node_modules\webpack-cli\bin\cli.js:41
)} manually.`,
^
SyntaxError: Unexpected token )
at Object.exports.runInThisContext (vm.js:76:16)
at Module._compile (module.js:542:28)
at Object.Module._extensions..js (module.js:579:10)
at Module.load (module.js:487:32)
at tryModuleLoad (module.js:446:12)
at Function.Module._load (module.js:438:3)
at Module.require (module.js:497:17)
at require (internal/module.js:20:19)
at runCli (○○\CubismSdkForWeb-4-r.3\Samples\TypeScript\Demo\node_modules\webpack\bin\webpack.js:54:2)
at Object. (○○\\CubismSdkForWeb-4-r.3\Samples\TypeScript\Demo\node_modules\webpack\bin\webpack.js:147:2)

[チュートリアル]
https://docs.live2d.com/cubism-sdk-tutorials/sample-build-web/
※npm: build - Samples/TypeScript/Demoの実行時、上記エラーが表示されます。

[環境]
VisualStudioCode 1.57
node: v6.9.5
npm: v4.0.5
Windows10 x64 20H2

コメント

コメントするにはサインインまたは登録して下さい。