Live2Dに関するユーザーのみなさま同士の交流・ご質問・不具合の報告・提案・要望などについて是非お寄せください。
※Live2D公式スタッフからの発言や回答については確約できないことを予めご了承ください。
Cubism 製品のマニュアル・チュートリアルはこちら
 
Cubism Editorマニュアル    Cubism Editorチュートリアル    Cubism SDKマニュアル    Cubism SDKチュートリアル
【年末年始のスタッフによる回答について】

いつもLive2Dをご活用いただきありがとうございます。

株式会社Live2Dは、2019年12月28日(土)から2020年1月5日(日)まで休業いたします。
年末年始の営業について
また、コミュニテイへの回答に関しては1月6日からを予定しております。
(※投稿内容によってはLive2D社スタッフからの回答を行わない場合もございます。)

なお、コミュニティ自体は年中無休で稼働しておりますため、
お気づきの点やご意見などは通常どおり書き込んでいただくことが可能です。

ユーザー様同士のコミュニケーションや回答ももちろん歓迎しておりますので、ご活用ください。

2020年も、変わらぬご愛顧を賜わりますよう、お願い申し上げます。

パーツ表示

Animatorで、「パーツ表示」の数値を100にしているのですが、画像が出てきません。
Modelerの方ではフォルダが非表示にしてあって、それをAnimatorで表示させるようにしようとしてます。
Modelerで表示していたものを0にして非表示にする事は可能なのですが、逆が出来ない状態です。

コメント

  • 実際に同様の状況で制作したことがないので、これが正解かは分かりませんが、
    思い当たることを記載します。

    恐らくですが、Animator側がmodelerの表示状況をそのまま出しているだけかと思います。
    なので、modeler側では非表示にしたいパーツも全て表示にした状態で、
    Animator側の1フレーム目で不要なパーツのパーツ表示を0にして対応する…ということかと思います。
    (上記をやりたくないので、このご質問をされているのかと思いますが…)

    モデル側での状態をAnimator側でいじれてしまうと、
    モデルを変更した場合に意図せぬ挙動が起こる可能性があるので、上記のような設定になっているものと思われます。
    最初のキーフレームが何に設定されていても、モデルを差し替えてしまったら違う表示になるということですので…
    非表示にしたものは「書き出さない」扱いにされているのではないかと思っています。
  • 「modeler側では非表示にしたいパーツも全て表示にした状態で~」のやり方を避けたかったんですがどうにも出来なさそうです…
    全部表示状態にしてパラメータでデフォルトの透明度を0%にしたりとかもしたのですが、やはり理想の通りにはならず…
    元々の仕様なのであれば公式から回避策を提示してほしいですね
  • 信号機 様
    rei 様


    ご連絡誠にありがとうございます。
    Live2Dスタッフのenokoでございます。

    この度はご不便をおかけしており誠に申し訳ありません。
    Modeler側で非表示のパーツがAnimatorの値が100の時に表示されない問題の現象は不具合でございます。
    こちらは順次改善予定となっておりますので、大変恐縮でございますがしばらくお待ち下さいませ。

    ご迷惑をおかけしており申し訳ありませんが、
    今後ともお引き立ての程宜しくお願い申し上げます。
コメントするにはサインインまたは登録して下さい。