新しいLive2D公式コミュニティ(日本向け)が公開されました!
ぜひご利用ください!
Live2D公式コミュニティ

■このコミュニティの今後について
このコミュニティ(forum.live2d.com)につきましては、しばらくの間新コミュニティと並行して運営しますが、2022年内を目処に閉鎖する予定です。
閉鎖時期や内容については決定次第お知らせいたします。
海外向けコミュニティについては変更ございません。
【各最新OSの対応状況について】
Cubism Editorは 4.1.02 正式版以降でWindows 11 及び macOS Monterey に対応しております。ぜひ最新版をご利用ください。
※macOSをお使いの方でOSアップデートする際は必ずCubism Editorのライセンスを解除してください。
Cubism EditorをインストールしているmacOSをアップグレードしたい
Cubism SDKについては各SDKのREADMEまたはNOTICEをご確認ください。

【Mac各機種への対応状況について】
現在、Cubism EditorはApple M1チップ搭載機種には対応しておりません。
詳細は 動作環境 をご参照ください。
関連するお問い合わせへの対応はこの文章をもって代えさせていただきます。
Cubism 製品のマニュアル・チュートリアルはこちら
 
Cubism Editorマニュアル    Cubism Editorチュートリアル    Cubism SDKマニュアル    Cubism SDKチュートリアル

cocos2d-x 3.4でLive2Dのモデルを表示できません。

編集済: 3月 2015 Cubism SDK 2.1
こんにちは。表題の件につきまして、どなたかアドバイスを頂けると幸いです。

【作業環境】
・mac OSX 10.10.2 / Yosemite
・Xcode 6.2
・Cocos2d-x 3.4
・Live2D SDK OpenGL_2.0.06_1

【状況】
・まず、SampleLive2DSprite.hで以下のようなエラーが出てビルドに失敗するので、修正しました。


void draw(cocos2d::Renderer *renderer, const cocos2d::kmMat4 &transform, bool transformUpdated);
void onDraw(const cocos2d::kmMat4 &transform, bool transformUpdated);

・iOSシミュレーターを使用しています。
・ビルドすると、ビルドは成功しますが、Live2Dのモデルが表示されません。
・Cocos2d-xのサンプルは正常に表示されています。
・ログにはエラー文がいくつか表示されています。

<エラー文>
OpenGL error 0x0500 in /Users/UserName/Live2dTestProject/cocos2d/cocos/renderer/CCTexture2D.cpp initWithMipmaps 640
OpenGL error 0x0500 in -[CCES2Renderer resizeFromLayer:] 146

エラーコードについて調べてみましたが、解決方法は見つけられませんでした。。。


・また、次にこちらの【記事】を参考にして同じコードで試してみました。
・ビルドは成功、OpenGL errorなどのエラーは出ませんが、Live2Dのモデルは表示されませんでした。


長くなりましたが、以上です。
ご教示いただければ幸いです。
タグ付けされた:

コメント

  • Cocos2d-xのサンプルが正常に表示されて、Live2Dのモデルが表示されない、というのは
    以下のような画面になるということでしょうか?


    この場合であれば、リソースの追加漏れだと思います。
    mocやpng等をxcodeのリソースディレクトリにドラッグアンドドロップしてみてください。


    これでちゃんとモデルも表示されるようになるかと思います。

    1.png 38.8K
    2.png 121.4K
    3.png 89.9K
  • t_takasakaさん、ありがとうございます。

    >Cocos2d-xのサンプルが正常に表示されて、Live2Dのモデルが表示されない、というのは
    以下のような画面になるということでしょうか?

    はい、以下の画面になります。
    本来であれば、添付いただいた画像のようにこの中央にモデルが表示されるはずなのですが…



    また、リソースファイルは追加されております。



    なお、Xcodeにリソースファイル追加する際のOptionについては
    どの項目にチェックを入れておりますでしょうか。
    もしかすると追加の仕方に問題があるのでしょうか…?

    自分のリソースファイル追加の手順は以下のとおりです。
    1:Finder上でリソースファイルをコピー&ペーストする
    http://sites.cybernoids.jp/cubism2/sdk_tutorial/platform-setting/cocos2d-x/3-cocos2d-xnorisosu-zhui-jia
    2:Xcode上でリソースファイルを追加する


    以上です
    よろしくお願いします
  • 編集済: 3月 2015
    cocos2dx3.0用のサンプルをcocos2dx3.4で動かしたときに同件発生することを確認しました。
    上でご報告いただいたdraw()とonDraw()の引数を見るに、yryr様も3.0用のサンプルを
    使っておられるのではないかと思うのですが、当たっておりますでしょうか?

    cocos2dxは3.2で描画周りの関数に若干変更がありまして、3.2以降で3.0用のサンプルを使うと、
    引数の指定が古いdraw()やonDraw()が、本来必要なdraw()やonDraw()とは
    別物と見なされてしまうため、呼ばれません。
    (draw()やonDraw()内でブレークポイントを張っていただくと分かるかと思うのですが、
     呼ばれていないので止まりません。
     描画周りの関数が呼ばれていないため、モデルも表示されなくなっています)

    「sample_cocos2dx3.2」のサンプルをお使いいただくと、特に問題なく動作するかと思うのですが、
    そちらで試してみていただけますでしょうか?

    リソースファイルの追加方法に関しては、上述されておられるやり方で問題ないかと思います。
  • t_takasakaさん、ありがとうございます。

    >yryr様も3.0用のサンプルを
    使っておられるのではないかと思うのですが、当たっておりますでしょうか?

    ご指摘の通り、公式マニュアル
    http://sites.cybernoids.jp/cubism2/sdk_tutorial/platform-setting/cocos2d-x/5-live2dwo-miao-huasurutamenokodo)を参考に作成しておりましたので、3.0用だったようです。

    sample_cocos2dx3.2/Simple/Classes/の使用で、
    シミュレーターで正常にモデルを表示することができました!
    本当にありがとうございます!
    簡単なことに気づけずお騒がせしました。


    なお、3.3以降からGLViewに関する変更が更にありましたので、
    サンプルのAppDelegate.cppの30行目に修正を加えました。

    修正前 glview = GLView::create("Live2D Sample");
    修正後 glview = GLViewImpl::create("Live2D Sample");

    参考記事
    GLViewにcreateが無くなった(cocos2d-x v3.3 rc0)
    http://qiita.com/YosukeMitsugi/items/26e36b05c96ea1480602
  • 編集済: 5月 2015




    I can't see model in cocos2d-x3.5
    error message is "OpenGL error 0x0501 in ..\renderer\CCRenderer.cpp cocos2d::RenderQueue::restoreRenderState 170"
  • 編集済: 5月 2015
    Hi JasonZhang

    Thank you for reporting.

    This bug might occur when using the AMD graphics board with Live2D SDK version 2.0.06.
    I want you to try the Live2D SDK version 2.0.04.
    The same problem occurs?

    In addition, the computer that you are using a desktop? Or laptop?
    (It is the graphics board that your are using RadeonR7 2xx? Or RadeonR7 "M" 2xx?)
  • thanks,i using desktop computer,and AMD graphics board is Radeon R7 200.
    now i want to try run in android, i use "Simple\proj.android\build_native.py" but i can't build,how can i do it?
  • Hi JasonZhang

    Could you show me the error log of build_native.py?

    Also, please tell me what compiler you are using? (Visual Studio? Eclipse?)
    And what is the version of the compiler?
コメントするにはサインインまたは登録して下さい。