新しいLive2D公式コミュニティ(日本向け)が公開されました!
ぜひご利用ください!
Live2D公式コミュニティ

■このコミュニティの今後について
このコミュニティ(forum.live2d.com)につきましては、しばらくの間新コミュニティと並行して運営しますが、2022年内を目処に閉鎖する予定です。
閉鎖時期や内容については決定次第お知らせいたします。
海外向けコミュニティについては変更ございません。
【各最新OSの対応状況について】
Cubism Editorは 4.1.02 正式版以降でWindows 11 及び macOS Monterey に対応しております。ぜひ最新版をご利用ください。
※macOSをお使いの方でOSアップデートする際は必ずCubism Editorのライセンスを解除してください。
Cubism EditorをインストールしているmacOSをアップグレードしたい
Cubism SDKについては各SDKのREADMEまたはNOTICEをご確認ください。

【Mac各機種への対応状況について】
現在、Cubism EditorはApple M1チップ搭載機種には対応しておりません。
詳細は 動作環境 をご参照ください。
関連するお問い合わせへの対応はこの文章をもって代えさせていただきます。
Cubism 製品のマニュアル・チュートリアルはこちら
 
Cubism Editorマニュアル    Cubism Editorチュートリアル    Cubism SDKマニュアル    Cubism SDKチュートリアル

キーフォーム編集ウィンドウの不具合

日々開発お疲れさまです。

不具合らしき症状に遭遇しましたので書き込みさせていただきます。



【環境】
Live2Dバージョン:4.0.08 beta1
OS:WIndows10
CPU:i9 9900k
メモリ:128GB
GPU:RTX2070

私の環境では以下の手順で症状が再現します。

https://twitter.com/hatyati/status/1368915790431354881

どうやらパラメータの最小値と最大値が違う複数のパラメータに割り当てられた状態でキーフォーム編集ウィンドウを使用すると発生するようです。

一度症状が発生すると編集中のモデルを開き直しても症状は継続します。
Live2DやPCを再起動すれば継続しませんが、同じ手順を踏めば再発します。

ログウィンドウに赤文字(エラー表示)は出ていません。

また、毎回挙動が同じというわけではなく、片方は正常に動く場合もあれば、そもそもキーフォーム編集ウィンドウの目盛りクリックが反応しない場合もありました。
キーフォーム編集ウィンドウを再度開くと症状(クリックの反応の有無や入力される数値が変化する)が変わることもあります。

4.0.08 beta1はリリースされた直後に入れているので1ヶ月弱使用しています。
いつごろから発生していたのかはわかりませんが、症状に気がついたのは今日になります。

あまり検証ができていない状態での書き込みになりますが
Live2D側の問題なのか、私のPC環境によるものか判断がつかなかったため投稿させていただきました。

お手数をおかけしますが
Live2D社側でも検証いただけますと助かります。

よろしくお願い致します。
[削除されたユーザー]

コメント

  • @hatyati

    ご連絡誠にありがとうございます。
    Live2Dスタッフでございます。
    いつも弊社製品をご愛顧くださり誠にありがとうございます。

    ご不便をおかけし申し訳ございません…
    詳しくお調べしたところ、こちらの現象は4.0.08 beta1で発生した不具合であることがわかりました、
    次回の更新で修正予定となっておりますので、今しばらくお待ちいただければ幸いでございます。

    何卒宜しくお願い申し上げます。
    hatyati
コメントするにはサインインまたは登録して下さい。