【macOS 11.0 Big Surへの対応状況について】
現在公開中のCubism Editorは、以下のバージョンではmacOS 11.0 Big Surには対応しておりません。
・Cubism Editor 4.0.07 beta 以前のバージョン
上記バージョンでは正常に動作できない可能性がありますので、OSのアップグレードをお控えいただくか、【Cubism Editor 4.0.07 正式版】をご利用いただきますようお願いいたします。
関連するお問い合わせにつきましては、この文章をもって代えさせていただきます。
Cubism SDKにつきましては、現在公開中の製品全てにおいてmacOS 11.0 Big Surには対応しておりません。
現在対応検討中となりますが、対応バージョンや時期につきましては改めてお知らせいたします。

またApple Sillicon版のmacにつきましても、全てのCubism 製品において対応しておりませんのでこちらも合わせてご了承ください。
Cubism 製品のマニュアル・チュートリアルはこちら
 
Cubism Editorマニュアル    Cubism Editorチュートリアル    Cubism SDKマニュアル    Cubism SDKチュートリアル

ワープデフォーマの不具合

お世話になっております。

本日はじめて見る不具合に遭遇し、
解決方法はおろか発生条件も分からなかったため書き込みさせていただきます。

①まず始めに、Live2Dモデル製作中、ワープデフォーマのベジェ分割よりも外側にデフォーマの頂点が配置されていることに気が付きました。
(どの段階からこうなっていたのかはわかりません)
(デフォーマの頂点が選択されているのは頂点の位置を見やすくするためです)


②単なる表示のミスと思いLive2Dを再起動したところ、
データ上はが存在しているにもかかわらずビュー上では不具合の発生したワープデフォーマだけ表示されなくなり、内包されているアートメッシュも形が崩れてしまいました。


この状態で該当のワープデフォーマの操作や削除が行えなくなり、中のアートメッシュも操作不能になりました。
不具合ワープデフォーマの親にワープデフォーマを作成する事はできましたが、子を作成する事はできませんでした。

また、ログには大量のエラー文が表示されており、
ビュー上で右クリックができず、Live2D Editorの操作も全体的に非常に重くなってしまいました。


幸い、バックアップファイルから①の時点まで戻り、
子デフォーマを作成し統合したところ不具合はなくなり、現時点で再発はしていません。

とはいえ今後も似たような不具合に見舞われるのは精神衛生上キツイので、報告させていただきます。
ですが、正直言葉だけでは説明が難しいので、該当デフォーマと子アートメッシュを入れたcmp3ファイルを用意しています。

お渡ししたいので、公式スタッフ様がこのディスカッションをご覧になられたならデータの受け渡しについてご教授いただけますと助かります。

よろしくお願いします。

コメント

  • hatyati様

    ご質問誠にありがとうございます。
    Live2Dスタッフでございます。
    いつも弊社製品をご愛顧くださり誠にありがとうございます。
    この度はご不便をおかけし誠に申し訳ございません…

    現象について詳しくお調べいたしますので、
    以下をご提供いただければ幸いでございます。

    ・ログファイル全文と、cmp3ファイルをDMでお送りください
    ・ご利用のCubism Editorのバージョンをご教示ください
    ・ご利用のPC環境をご教示ください

    お手数をおかけし申し訳ございませんが、
    何卒宜しくお願い申し上げます。
  • enoko(staff)様

    返信いただきありがとうございます。
    先ほどDMの方を送りましたので確認のほどよろしくお願い致します。

    (もしDMのやりかたが間違ってましたらお知らせ下さい)
    • バージョン:Cubism Editor 4.0.04 beta1
    • CPU:Core i9 9900K
    • メモリ:64GB
    • GPU:RTX2070
    • OS:Windows10 pro 64bit

    お手数おかけしますが、
    よろしくお願いいたします。
  • enoko(staff)様

    追記
    4.0.05 beta1でも試してみましたが、結果は同じでした。

    よろしくお願いいたします。
  • hatyati様

    ご連絡誠にありがとうございます。
    (申し訳ございません、DMの送信方法のご案内が抜けてしまっておりました…
    お送りいただいた形であっております)

    4.0.05 beta1でも結果は同じとのこと、承知いたしました。
    お送りいただいたファイルを確認させていただきます。
    お急ぎのところ誠に申し訳ございませんが
    しばらくお時間をいただければ幸いでございます…

    何卒宜しくお願い申し上げます。
    hatyati
  • hatyati様

    Live2Dスタッフでございます。

    ただいま調査を進めております。
    より詳しくお調べするため、たびたびお手数をおかけし申し訳ございませんが
    バックアップファイルから①の段階に戻ったモデルから
    当該のパーツのcmpを書き出してDMにてお送りいただけますでしょうか…

    何卒宜しくお願い申し上げます。
  • enoko(staff)様

    調査いただきありがとうございます。
    先程DMにて①の状態のcmp3ファイルを送りましたので確認のほどよろしくお願いします。

    現在別の構造で制作を進めており、今のところ症状の再発はありません。
    そのため緊急を要するわけではありませんが、調査のほどよろしくお願い致します。
  • hatyati様

    ご連絡誠にありがとうございます。
    調査を進めてまいります。

    ご不便をおかけし申し訳ございませんが、
    今しばらくお時間いただけますと幸いでございます。
    進捗がありましたらご連絡を差し上げます。
    何卒宜しくお願い申し上げます。
    hatyati
  • hatyati様

    Live2Dスタッフでございます。
    ご連絡が遅くなってしまい誠に申し訳ございません。

    本不具合は先日リリースされました4.0.06 beta1で修正対応が完了いたしました。
    長らくおまたせしてしまい申し訳ございませんでした。
    また問題がございましたらご報告いただければ幸いでございます。

    今後とも弊社製品をお引き立ての程宜しくお願い申し上げます。
    hatyati
  • enoko(staff)様

    これで安心してLive2Dモデルの制作ができます!
    この度は対応いただきありがとうございました。
コメントするにはサインインまたは登録して下さい。